KTM 1090 Adventure Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Has anyone noticed that when coming to a stop with clutch engaged and in gear that the idle fluctuates? I have noticed this since day one and now have about 2500 miles on the bike.
 

·
Registered
Joined
·
139 Posts
Has anyone noticed that when coming to a stop with clutch engaged and in gear that the idle fluctuates? I have noticed this since day one and now have about 2500 miles on the bike.

I tried this out just for you :wink2: I'm at 5200km. I took the bike for a ride yesterday and my bike idles in gear with the clutch engaged while coming to a stop between 1500 and 1250 and is pretty stable.


What type of result/fluctuation are you seeing?
 

·
Registered
Joined
·
7 Posts
My idle was fluctuating when it was 2 weeks old. Did the run from cold to reset the low and high idle. No issues since.
1090 manual says until the operating temperature is reached, I know earlier models 990 and 1290 you had to run it for 15 minutes.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #5 ·
Maybe I should have clarified. My erratic idle is not when starting bike. It occurs after motor has been warmed up and ridden for 5-10 miles, then stopping at a light, holding clutch lever in while in 1st gear the rpms fluctuate up and down. I will try and post a video of it next time I ride.
 

·
Registered
Joined
·
139 Posts
Maybe I should have clarified. My erratic idle is not when starting bike. It occurs after motor has been warmed up and ridden for 5-10 miles, then stopping at a light, holding clutch lever in while in 1st gear the rpms fluctuate up and down. I will try and post a video of it next time I ride.



As I stated, when my bike is warm and at a stop in fist gear the idle fluctuates between 1500 1250 rpm.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #7 ·
Maybe just another quirk the KTM has. Doesn’t make me like the bike any less. I didn’t know if I was alone with this experience as no one else has commented on it yet.
 

·
Registered
Joined
·
11 Posts
I'm not really getting an erratic idle but seems like it's recently not as smooth and the engine has actually cut out on me a couple times. No check engine light is visible so I at least don't have any active codes thrown. Another really weird thing that happened to me the other day was the instrument panel was completely shut off while the bike was running. As in I couldn't even see my RPMs while I was driving down the street or if I was in neutral when I pulled over. I had to cycle the bike off-on before I could see it again. I love this bike but I'm really starting to question reliability; it only has 1100 miles.
 

·
Registered
Joined
·
65 Posts
My idle was never smooth, but seemed to get worse around 1400 miles, actually stalled trying to accelerate at a green light a couple times. Problem went away after installing the O2 sensor delete kit (also lost about 1 gal/hr fuel burn rate).
 

·
Registered
Joined
·
139 Posts
I'm not really getting an erratic idle but seems like it's recently not as smooth and the engine has actually cut out on me a couple times. No check engine light is visible so I at least don't have any active codes thrown. Another really weird thing that happened to me the other day was the instrument panel was completely shut off while the bike was running. As in I couldn't even see my RPMs while I was driving down the street or if I was in neutral when I pulled over. I had to cycle the bike off-on before I could see it again. I love this bike but I'm really starting to question reliability; it only has 1100 miles.



I would contact your dealer and inform them of the dash issue and also mention the idle issue. I'm at 5,500 KM's and I have never had either of these issues.
 

·
Registered
Joined
·
10 Posts
My brand new 1090 does the same.... I was hoping that once the break in was complete it might smooth out. IMO this bike is appearing to not be as refined as one would expect from a bike with a $15k price tag
 
1 - 11 of 11 Posts
Top